Knowledgebase: cPanel > Software > Select PHP Version
Select PHP Version
Posted by Matthew Jeffels, Last modified by Paul Nesbitt on 19 July 2016 05:15 PM

Select PHP Version

Select PHP Version allows you to change the PHP version and modules in use for your hosting account.

This can be used if you require an older PHP version for your website or if the native version is being increased but your website will break on the newer version you can simply select the version you need.

All PHP versions have been patched however to have the latest security fixes and optimizations using HardenedPHP from Cloud Linux.

Changing Versions

To Change the PHP version simply select the version you wish to use from the drop down menu then click "Set as current"

You will notice you cannot change the native PHP version modules as it is not possible, however if you need to you can simply select the same PHP version as the native from the drop down list and this will allow you to then customise the modules in use.

Php Version Selection

Once you have selected a version of PHP you can then choose the modules that you wish for it to have which should appear below;

PHP Select Modules

Make sure to click both set as current and save other wise changes will not be made;

Additionally you can change some of the PHP settings for your PHP choice by clicking on "Switch To PHP Options";

 

Once in the options you can change a range of settings to meet your needs;

PHP Options

Once again make sure to click save.

To return to the native version of PHP simply select it and click "Set as current"

Thanks

Matt Jeffels
PAC Web Hosting

(1 vote(s))
Helpful
Not helpful

Comments (0)